Instead of calling the property "MovementCost" 1 could it not be named a bit different. I don't think that the movementCost definition is self explanatory. Also, maybe the concept could be expanded or made ready to also allow movement modifiers upon exit from territory. Maybe:
"EntryMovementCostModifier" "1" If it would cost an extra move to move into. And "-1" if it was free of cost to move into. Who knows, maybe units/maps/mapmakers would have reasons to let a unit pass into specific territories for free or less cost.
"ExitMovementModifier" "1" or "-1" with the same logic as above, if this was also implemented.
Also, what are your thoughts about fuel consumption when affected? Would it make sense to just make fuel follow the moves, meaning if it cost extra move then it cost extra fuel. Less move would mean less fuel. Free move would be no fuel?