assigning paratrooper tech

  • Hi there,

    how does one assign a particulat technology to a faction, from the beginning? I'm trying to get Zeppelins in the Middle Earth maps to transport Dwarves, but although I've added isAirTrasport and isAirTransportable to Zeppeling and dwarf units I can't get this to work. I suspect I need to give the dwarves the paratrooper technology, but don't know how.

  • Here is what I have done so far, I have

    a) add the paratroopers to the technologies list

    <techname name="paratroopers"/>

    b) attach this technology to the players

    <attachment name="techAttachment" attachTo="Saruman" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player><option name="paratroopers" value="false"/>
    <attachment name="techAttachment" attachTo="Dwarves" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="paratroopers" value="true"/>

    c) added this to Zeppelins

      <option name="isAirTransport" value="true"/>
      <option name="transportCapacity" value="1"/>

    d) and this to dwarves

      <option name="isAirTransportable" value="true"/>

  • @Marc-Sarzi I suspect that the dwarves have an option like:

       <option name="transportCost" value="2"/>

    So the Zeppelins transportCapacity will need to be equal or greater then that to transport the dwarves.

    You also might what to check the:

    <property name="Tech Development" value="true" editable="true">


  • Moderators

    You are a King amongst men LOL : )

  • @wc_sumpton thanks.

    I do not need to transport all troops, such as cannons that indeed have a transport cost of two. I am more interested in having the ability to move infantry, which has a transport cost of one.

  • folks, I'm pretty stuck. I really do not understand how to make my zeppelings air transportable. I've added

    <delegate name="tech" javaClass="games.strategy.triplea.delegate.TechnologyDelegate" display="Research Technology"/>
    <delegate name="tech_activation" javaClass="games.strategy.triplea.delegate.TechActivationDelegate" display="Activate Technology"/>

    at the beginning of the xml to allow tech development and later

      <step name="dwarvesTech" delegate="tech" player="Dwarves"/>
      <step name="dwarvesTechActivation" delegate="tech_activation" player="Dwarves"/>

    in the dwarves game sequence, and add tech development as an option. But nothing, tech research does not appear for my dwarves. Also I've tried to put <option name="paratroopers" value="true"/> but I don't get this at the start as it should be. In fact I've tried to do the same in pact of steel but it looks like you still have to develop the tech. Would anyone be willing to take a look at my .xml?

  • Moderators


    Go ahead and post the xml. Someone will look at it. I'll even look at it, although probably won't be much help lol

  • @Marc-Sarzi I'm sorry to say (or happy to say, depends on how you want to look at it), but I don't think that xml is the problem. When you load up the map and select the dwarf and tap it onto the zeppelin do you get the "How many zeppelins to load?" prompt. If so then air transport is working. You need to check the prompt carefully, the default value, unlike transports, is "0". So if you hit "OK" then the game thinks that you are moving the zeppelin and dwarf together and not transporting the dwarf. You have to select the number of zeppelins to use. After that you will be prompted about the dwarves. Again the default is "0", so you have to change it to the number of dwarves to be loaded.

    If you are not getting these prompts, the yes something may be wrong with the xml. But with what you are telling us the only thing I can think is the 'Un-user friendliness' of the loading.

    Trying as always to help.


  • @wc_sumpton thanks a lot. I'll attach below my present .xml in the next post. I can see how air transport works in other ww2 scenarios, but - by the way - I have not managed to have this tech (or any other) working straight from the beginning, without having to roll for it. That's what I'd like to have in place for my dwarves, but as I was despairing on it in the .xml I'll attache I've tried to simply have them being able to purchase tech dices.

  • middle_earth_12player_Marc.xml

    Here's my slightly modified Middle Earth map. Now featuring 9 starting Nazguls, a starting Balrog in Moria and 6 2-hit and artillery supporting Wizards (Saruman, Gandalf with Free Folk + Radagast, Galadriel & Elrond for the Elves). No Wizard, Barlog and Nazgul purchases. Elves also get Elk Riders instead of Griffins. These are like Heavy cavarly but can be artillery supported to work in tandem with elf Rangers. I have also made the 10 Gondor one-off undead units much stronger.

    This map tries to redress the previous unbalance whereby Evil was weaker. Now it's a bit the other way around, in particular up in the north east. Which is why I wanted to boost the Dwarves with a bit of paratropper Zeppelings.

  • @Marc-Sarzi Sorry it took so long, I work a 10hr shift. I've skimmed over the xml, and could not find what has caused your problem. So let try and force the issue by add a trigger to set the technology:

    <attachment name="conditionAttachmentAlwaysTrue" attachTo="Dwarves" javaClass="games.strategy.triplea.attachments.RulesAttachment" type="player">
    	<option name="switch" value="true"/>
    <attachment name="triggerAttachmentUseTransports" attachTo="Dwarves" javaClass="games.strategy.triplea.attachments.TriggerAttachment" type="player">
    	<option name="conditions" value="conditionAttachmentAlwaysTrue"/>
    	<option name="tech" value="paratroopers"/>
    	<option name="when" value="before:dwarvesPurchase"/>
    	<option name="uses" value="1"/>

    I added the 'AlwaysTrue' condition to insure the trigger will fire when it is needed.

    Next add in the 'Use Trigger' property:

    <property name="Use Triggers" value="true" editable="true">

    Now load and test. You should check the 'Players' tab on the right and look and see if the Paratroopers tech is there, and is it assigned to the dwarves. Also check the game history to see if the trigger did fire.

    Hoping to find the answer!


  • @wc_sumpton thanks a lot! Yes this works, although I'm not sure why things were not working before...

  • @Marc-Sarzi that's good to hear! I would like to know also, but it would be hard to figure it out without the whole map to test the xml against. I do know that you could comment out the tech, tech_activation lines, along with the lines assigning them to the Dwarves sequence.

    If you plan on using Tech Development later don't forget to add 'techTokens' as a resource, that is why Dwarves could not develop 'paratroopers':

       <resource name="techTokens"/>

    Again thanks for keeping me posted!


  • @wc_sumpton actually, adding the techTokens made my earlier approach work (in my first attach .xml file) so no need for triggers!

Log in to reply