Churchill's 1939



  • I've been working on a map called Churchill's 1939, based on Charles de Gaulle Neutrals 1939. My aim with it is to add as many playable nations as possible. The new nations I'm adding are:
    -Balkan/Danube Axis, basically all the Balkan Pro-Axis neutrals as one player (not implemented yet, will use Italians_blue units with some changes)
    -Benelux, consisting of the Belgian and Dutch colonial empires (built on top of existing Dutch code)
    -Canada, because I'm Canadian (inspired by the 1940 House Rules with Canada mod)
    I have made it so that Pro-Axis/Allied neutrals are also playable but have been limited by territory restrictions.
    However, I have posted this here due to a problem I have been having. While play testing I have noticed that Benelux cannot do anything for some reason even though I put in code allowing for it's own turn. Also, the game starts to sort of break past the 1st round- I haven't tested it further but sometimes Germany can't move or players are prevented from producing.
    I am posting this here along with some cool unit images I have made for C39.

    https://drive.google.com/drive/folders/160moDoGO2dJIJ-eDYw_tlwOkNjfAa9L3?usp=sharing



  • @JOSEPH-PRINCE

    First off there are a lot of xml's in you file, and some of the 'name's in the xml's are the same which makes it hard to figure out which xml to check. Try attaching 'old' or 'modified' to the back of the name to help keep them strait.
    For xml 'alexander_papagos_1939.xml'

    <game>
      <info name="Churchills 1939 - old" version="1.24"/>
    

    This way it would not be confused with xml 'churchills_1939.xml' which has the same game name.

    In 'churchills_1939.xml' there were a lot of '</step>' which caused the game not to load. And both the French and Canadians had no closing '/' at the end of their 'endTurn' lines.

       <step name="canadiansPlace" delegate="place" player="Canadians"/>
       <step name="canadiansEndTurn" delegate="endTurn" player="Canadians"> <!-- Missing '/', that is needed here. --> 
    <!-- French Game Sequence -->
    <step name="frenchTech" delegate="tech" player="French"/>
    

    After these correction I was able to run the game. But it stopped on 'Canadians' turn because there was no capital for them.:

      <player name="Canadians" optional="false"/> <!-- 'false' means this player needs at least one capital territory. -->
    

    So I changed 'Quebec' to be the capital.

    <attachment name="territoryAttachment" attachTo="Quebec" javaClass="games.strategy.triplea.attachments.TerritoryAttachment" type="territory">
       <option name="production" value="2"/>
       <option name="unitProduction" value="3"/>
       <option name="capital" value="Canadians"/>
       <option name="victoryCity" value="1"/>
    </attachment>
    

    Now I was able to run the xml. Things seem ok, as I ran it about 3 turns. One thing I did notice was the way you have the British and UK Pacific players trying to use the same movement phases was not working as I think you are planning:

    <step name="britishPolitics" delegate="politics" player="British"/>
    <step name="britishCombatMove" player="British" delegate="move">
      <stepProperty name="combinedTurns" value="British:UK_Pacific"/> <!-- 'combinedTurns' really only deals with landing aircraft on carriers and not 
       much else. The two countries do not move and enter combat together. UK_Pacific does not get to CombatMove with the British. -->
      </step>
    <step name="britishAirborneCombatMove" delegate="specialCombatMove" player="British" display="Airborne Attack Move"/>
    <step name="britishBattle" delegate="battle" player="British"/>
    <step name="britishNonCombatMove" delegate="move" player="British" display="Non Combat Move">
      <stepProperty name="combinedTurns" value="British:UK_Pacific"/>
      </step> <!-- Same as above -->
    <step name="britishNoAirCheckPlace" delegate="placeNoAirCheck" player="British"/>
    

    Hope this is helpful.

    Cheers...



  • @wc_sumpton
    I followed all your advice- but could you elaborate on the "too many </step>" issue? I removed them but now the game doesn't show an error, but is not in the game list.
    churchills_1939.xml
    ^ updated .xml
    Other things I did:
    Fixed the missing / on the endTurn lines
    Made Ontario the Canadian capital
    Got rid of "alexander_papagos.xml" because it was an early development version

    Additionally, please help me with the previously mentioned issue with Benelux not being able to play, and thank you with the assistance as this is my first map/game.



  • @JOSEPH-PRINCE

    I get rid of nothing... but my own mistakes... which means I throw away a lot.😅 😵

    On the main screen, select 'Engine Preferences', then select the 'Game' tab. Third option down 'Show Console' set to true. This will give you better error messages in the console window!

    And keep MODING!!

    Cheers...



  • I fixed the image problems for your game and even added the Benelux flag. Will post here soon.

    200px-Benelux_vlag.svg.png



  • @RogerCooper Churchills_1939. I fixed various images problems. The XML was not changed.



  • Sorry, didn't see your reply sooner, the link to download the fixed XML does not work. Can you resend it?



  • Try this link



  • I noticed that the scenario is missing more images for anti-tank guns and tank destroyers.



  • Maybe instead of sending the .zip you could send just the xml? When I click the link it says "this page does not exist".



  • @JOSEPH-PRINCE Try this http://www.rogercooper.com/churchills_1939.zip

    There is no point to sending the xml, as I have not changed the xml. To make this work, you will need to create art for antitank and tank_destroyer. I don't know of any scenario that used those unit types.

    The Benelux flag is from https://en.wikipedia.org/wiki/Flag_of_Benelux.


Log in to reply