Unit Shows As Invisible No Matter What I Do


  • Donators

    I am converting an old scenario (HeartsofIron_Fatherland) to Version 1.9. Some images were not loading. One of them was for the unit "fighterjet". I saw that in the units folder, the unit was "fighterJet". I tried to correct this by renaming, but it still failed. I then tried renaming to "fighter_jet" and then "jet_fighter", but the error stubbornly remains. The exact message is

    MISSING IMAGE (this unit or image will be invisible): UnitType{name=jet_fighter}

    You can download the file HearsofIron_Fatherland. Does anyone see why this is not working?


  • Admin

    @RogerCooper It appears this map was a separate mod of hearts of iron which are no longer supported in 1.9. The reason it doesn't find the images is that its only looking here:
    Loading resources from the following paths: [C:\maps\hearts_of_iron.zip, C:\Users\ron\Documents\GitHub\triplea\assets]

    To resolve this you should either do:

    1. Merge this into hearts_of_iron (copy game XML and any needed images into it so you have just 1 zip with 2 games)
    2. Copy all assets from hearts_of_iron to HeartsofIron_Fatherland so its a standalone map and then update the name property in the game XML so it no longer points to hearts of iron:
      <property name="mapName" value="Hearts of Iron" editable="false"/>