Non Combat Move - Disable issue



  • Not sure if this is a bug or I am doing something wrong.
    I have been disabling the "Non Combat Move" step in games where I never use it.
    ie;
    <!--
    <step name="MacedoniaNonCombatMove" delegate="move" player="Macedonia" display="Non Combat Move">
    <stepProperty name="repairUnits" value="true"/>
    </step>
    -->

    Have not had a problem on other maps, but on 270BC_40% Sometimes I get "Not all units have enough movement"
    On the second turn in combat movement. (This on a single unit that has not yet moved)

    The weird thing is, that if I only disable the empire I am playing, I never have the issue. But I tried to set all empires to have no "Non Combat Move". Then I began getting the error.

    Been trying to narrow done when it actually happens. I have it now to where if I disable "Non Combat Move" on all except GreekCityStates and I play Macedonia, then I do not get the error. GreekCityStates is the empire that moves just prior to Macedonia, may have something to do with it.


  • Donators Moderators Admin

    @mahks

    You might need to add one of these to the last move so everything that requires resets is forced to do it.

    excerpt from POS2

    resetUnitStateAtEnd = true/false at end of phase will resets movement points and other unit states such as submerged, amphibious, unload/load, wasInCombat, etc. (default at end of phase depends if delegate ends with "NonCombatMove")
    
    resetUnitStateAtStart = true/false at start of phase will resets movement points and other unit states such as submerged, amphibious, unload/load, wasInCombat, etc. (default is false)
    

    Most likely you want to use the "resetUnitStateAtEnd " with your last combat move (per player). Syntax would look like below.

    <step name="british_CombatMove" delegate="move" player="British" display="Attack Move">
    	<stepProperty name="resetUnitStateAtEnd" value="true"/> 
    	</step>
    


  • @general_zod resetUnitStateAtEnd fixed it thanks!