github update trouble


  • Donators

    @ssoloff not sure where to post this at git or here for that matter but this seems as good a place as any. I can't update. Here's what I get:

    0_1544231090693_Screenshot from 2018-12-07 18-46-47.png

    It's been a while since I've done it but other than the first time it's always worked pretty easily. I cloned from the map repo place. then opened the folder in my git repo and replaced the map. It seems as if I'm behind/not up to date or something. I don't remeber that happening before.

    I'm guessing I'm screwing up when I add the changes somehow, but pretty sure that's how i did it before. Adding the whole map I don't have to d with all the changes separately.

    Anyway if you would clue me in on where I'm messing up I'd appreciate it.

    Thank You

    So I found this:

    0_1544232643955_Screenshot from 2018-12-07 19-29-26.png

    unfortunately I don't understand it. Do I need some sort of admin approval before I can do anything ?


  • Donators

    @beelee so something totally fckd is going on now. It's deleting my Japanese units :

    0_1544245861575_Screenshot from 2018-12-07 23-10-22.png

    wtf on day 3 of this bs lol


  • Admin

    @beelee The error you're seeing is due to there being changes on the test branch on the remote repo (origin) that are not in your local repo. One way this can happen is if you have two local copies of the repo connected to the same origin, and you made different changes in each local repo.

    The most straightforward solution to the problem is exactly what the error message tells you to do: run the git pull command. However, this can fail if there are changes made to the same line(s). This results in a conflict and Git will tell you if this is the case after running git pull. If you run into this issue, I'll have to give you a primer on how you go about resolving conflicts. 😄

    It would be interesting to see how your local test branch is out of sync with the same branch on origin (https://github.com/triplea-maps/global_40_house_rules/commits/test). You can do that by running git log --stat and posting the output here.

    Just looking at the test branch on origin, it appears it is waaaay behind the master branch. In fact, I'm not sure it even has a common parent. I'm guessing when you started on your latest changes, you simply used the existing test branch from January 2018, and that you didn't start a new branch from the current master.

    One typically begins each new unit of work (a pull request in GitHub parlance) with something like git checkout -b my-new-branch master. That creates a new branch named my-new-branch so that it is basically a copy of master. Then you commit changes to that new branch and push them to origin. Once your pull request is complete, you would delete my-new-branch. When you're ready to start your second unit of work, you would repeat that process with a different branch (e.g. my-new-branch-2).


  • Donators

    @ssoloff thank you for your reply

    my apologies for my earlier frustration . I'm not real sure how my stuff can be out of date but I have enough to try something else. : )

    Thanks again


  • Donators

    @beelee so I took a break and tried again. Even more confused now.

    I kept getting there's nothing to compare in my PR etc... anyway I fired up triplea and the map has been updated. Unless I've completely lost my mind, I never updated "maps yaml". I never saw the PR show up on Git.

    Idk what's going on ? has the map update process changed in the last 6 months ?

    W/e it's updated but I'd like to understand it.

    Sorry for getting pissy earlier.

    Thanks


  • Admin

    @beelee Not 100% sure, but you did successfully update your map at some point yesterday so...

    Git is hard for people not used to it, I believe every developer hated it at some point in their career ^^
    But in the end it makes our lives easier and more importantly: It makes everything undoable


  • Donators

    @RoiEX Thanks for the reply. Yea Idk what happened here. Have updated several times and have never experienced this. Seems as if it upated itself. No yaml PR or maps one. Nothing in my email.

    Anyway gonna try again and see what happens.


  • Donators

    @beelee yea that's what it's doing. Auto update. I guess I missed where that had changed. Surprised you don't have to change the yaml. Was looking for something already done . Anyway a lot easier this way.

    However I'm having trouble with a new image not showing up. Used to be it'd throw an error but doesn't now. Nothing in the debug.

    I'm gonna try and drop and drag them in but it's weird that the notes and xml number all change and they don't. Double, triple checked and tried it several times now.

    See what happens this time

    ok finally got them to show up. Not sure what was up. Anyway should I update the yaml ? or do we not do that anymore ?


  • Admin

    @beelee You discovered the biggest flaw with the yaml approach.
    All incrementing the number in the yaml does is force a re-download of the map if the number your downloaded version is associated with is lower.
    So if you delete the map manually you will always get the latest version, just the way it is.