[Fixed] xml problem

  • Moderators

    Global 40 game mod. I have an objective activating when I don't want it to. It doesn't do it if I replicate at game start:

    mongolia doesn't activate sphere.tsvg

    But does at rd 11 Japan noncombatmongolia activates sphere rd 11 Japan non combat.tsvg

    It's sphere of influence for the russians in the objectives tab. They get minus PUs when allied units are in there territory.

    I think it has something to do with the changeOf Ownership trigger/thingy. When it changes from mongolia to russia the units also stay regular infantry and don't turn into Russian_infantry and the primitive units are also nation specific and they don't change either.

    I edit everything correctly and it works. I tried adding Russian_infantry image to Mongolians units and also tried another trigger removing the infantry and replacing with Russian_infantry after the changeOwnersip trigger.

    here's the xml before I tried any changes:


    Line23482 is the changeOwnership trigger

    Any help is appreciated as always : )


    Hmm...not sure if the xml loaded correctly. I'll try again.

    Well idk, it seems different, xml, than usual...

  • Moderators Admin

    @beelee Assuming this happens or would happen in a version currently or formerly available for download, I'm moving this to Bug Reports, since this is a map bug (in your own map).

    I'm not sure you explained the matter really well, or at least I had to focus a lot to understand what you are saying. May be I'm just being slow.

    Anyways, I loaded the savegame and I see that all those primitive units in the Mongolian territories are still Mongolians.

    I'm not sure, as I've not messed with these things recently, but my guess is that you are missing the "canBeCapturedOnEnteringBy" option on the "primitive". Just test it, see if I'm right.

  • Moderators

    @Cernel Thank you that fixed the primitive problem. The problem I still have is that Russia has nation specific infantry "Russian_infantry". Not all player's do yet, so I have to keep the generic "infantry" for russia as well. Only in it's unit folder not in the production frontier.

    When the mongolia infantry change to russian they change to the generic "infantry". I want them to change to the "Russian_infantry". So I added trigger ..._Mongolia_3 to try and do that:

    Screenshot from 2019-02-05 15-09-05.png

    That didn't work however and ending up throwing a null pointer error. You could skip pass the error and the game would still run.

    Screenshot from 2019-02-05 15-20-42.png

    This is the latest xml:


    So I think I need to figure out how to trigger the removeunits and placement trigger. Not sure how to write it

  • Admin

    @beelee The error indicates you are missing some image. At a quick glance, I think your trigger is trying to place Japanese "Russian_infantry" rather than Russian "Russian_infantry".

  • Moderators

    @redrum Thank you Yea japanese russian infantry would be in constant conflict with themselves lol

    I thought i switched it to russians the other day but i'll give it another go.

  • Moderators

    @beelee yea sadly that didnt work. Null pointer is fixed or at least not showing up : )

    Think i tried that a few days ago with russians. Anyway i think it should be possible. Maybe not, with the different infantries.

  • Admin

    @beelee Well, I think you need to separate the trigger into 2 separate ones as the "removeUnits" needs to be attached to Mongolia and the "placement" needs to be attached to Russia.

  • Moderators

    Right on, got it fixed. I like it when things work 😁 Ended up having to change the condition. Wasn't really sure what the _false did. Nothing, I assume, other than just being a condition. Don't really understand it, but...anyway this is the fix in case anyone comes across this and is interested.

    ![0_1550970991669_Screenshot from 2019-02-23 19-09-00.png](Uploading 100%)![0_1550971136245_Screenshot from 2019-02-23 19-09-00.png](Uploading 100%) ![0_1550971160786_Screenshot from 2019-02-23 19-09-00.png](Uploading 100%)

    well I guess it won't let me post a screenshot. I'll try again later

    Thanks again for everyone's help on this

Log in to reply