Bizzare issue - unable to roll dice



  • Hey guys,

    So I have the latest version of TripleA and the latest maps. I have been playing a game of Domination 1914 for weeks without issue. I download a save file, and simply play, roll dice, and post my turn.

    I started a second game with friends of 1940 BM3. And can't proceed due to "dice rolling" errors. It says it can't contact the server... (Yet there is still no issue with any games I play from my 1914 stream).

    I've tried troubleshooting this in some detail, and get some strange results. If I start a new domination 1914 game, and use all the same information from the existing game, it won't work. If I try to change all the email addresses in the new game, it won't work. if I isolate emails 1 by 1 it won't work. If I download the latest savegame files from other games, those dont work either.

    Only save game files from the 1914 domination game work!? I don't understand why? IF the issue was an email address, or firewall, or whatever, then that would be the problem and none of it would work, but it's just not the case, and I can't post in new games.

    The error is listed as below:

    javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    	at sun.security.ssl.Alerts.getSSLException(Unknown Source)
    	at sun.security.ssl.SSLSocketImpl.fatal(Unknown Source)
    	at sun.security.ssl.Handshaker.fatalSE(Unknown Source)
    	at sun.security.ssl.Handshaker.fatalSE(Unknown Source)
    	at sun.security.ssl.ClientHandshaker.serverCertificate(Unknown Source)
    	at sun.security.ssl.ClientHandshaker.processMessage(Unknown Source)
    	at sun.security.ssl.Handshaker.processLoop(Unknown Source)
    	at sun.security.ssl.Handshaker.process_record(Unknown Source)
    	at sun.security.ssl.SSLSocketImpl.readRecord(Unknown Source)
    	at sun.security.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)
    	at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
    	at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
    	at org.apache.http.conn.ssl.SSLConnectionSocketFactory.createLayeredSocket(SSLConnectionSocketFactory.java:396)
    	at org.apache.http.conn.ssl.SSLConnectionSocketFactory.connectSocket(SSLConnectionSocketFactory.java:355)
    	at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:142)
    	at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:373)
    	at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:381)
    	at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:237)
    	at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:185)
    	at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:89)
    	at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:111)
    	at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:185)
    	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:118)
    	at games.strategy.engine.random.PropertiesDiceRoller.postRequest(PropertiesDiceRoller.java:147)
    	at games.strategy.engine.random.PbemDiceRoller$HttpDiceRollerDialog.rollInSeperateThread(PbemDiceRoller.java:222)
    	at java.lang.Thread.run(Unknown Source)
    Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    	at sun.security.validator.PKIXValidator.doBuild(Unknown Source)
    	at sun.security.validator.PKIXValidator.engineValidate(Unknown Source)
    	at sun.security.validator.Validator.validate(Unknown Source)
    	at sun.security.ssl.X509TrustManagerImpl.validate(Unknown Source)
    	at sun.security.ssl.X509TrustManagerImpl.checkTrusted(Unknown Source)
    	at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(Unknown Source)
    	... 22 more
    Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    	at sun.security.provider.certpath.SunCertPathBuilder.build(Unknown Source)
    	at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(Unknown Source)
    	at java.security.cert.CertPathBuilder.build(Unknown Source)
    	... 28 more
    


  • Just updated Java to latest version - no effect


  • Moderators Admin

    @Gargantua This is related to outdated Java SSL certificates still present on your computer.
    Your TripleA still uses an outdated Java version that had been bundled with a very old installer despite you updated to the latest Java. Now you need to manually remove that old version.

    To find the culprit, please do this:
    -Start TripleA
    -Start a Local Game (any will do)
    -When the game has started find the Menu Debug and then click Show Console
    -When the Console has opened, click the button Properties
    -Then click Copy to Clipboard
    -Paste in this thread



  • @Panther SYSTEM PROPERTIES
    awt.toolkit=sun.awt.windows.WToolkit
    exe4j.consoleCodepage=cp0
    exe4j.isInstall4j=true
    exe4j.launchName=C:\Program Files\TripleA\TripleA.exe
    exe4j.moduleName=C:\Program Files\TripleA\TripleA.exe
    exe4j.semaphoreName=Local\c:_program_files_triplea_triplea.exe0
    exe4j.tempDir=
    exe4j.unextractedPosition=0
    file.encoding=Cp1252
    file.encoding.pkg=sun.io
    file.separator=
    install4j.appDir=C:\Program Files\TripleA
    install4j.exeDir=C:\Program Files\TripleA
    install4j.launcherId=33
    install4j.swt=false
    java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
    java.awt.printerjob=sun.awt.windows.WPrinterJob
    java.class.path=C:\Program Files\TripleA.install4j\i4jruntime.jar;C:\Program Files\TripleA.\bin\triplea-game-headed-1.9.0.0.13066-all.jar
    java.class.version=52.0
    java.endorsed.dirs=c:\program files\common files\i4j_jres\1.8.0_66\lib\endorsed
    java.ext.dirs=c:\program files\common files\i4j_jres\1.8.0_66\lib\ext;C:\WINDOWS\Sun\Java\lib\ext
    java.home=c:\program files\common files\i4j_jres\1.8.0_66
    java.io.tmpdir=C:\Users\JGREEN~1\AppData\Local\Temp
    java.library.path=C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\Skype\Phone;c:\program files\common files\i4j_jres\1.8.0_66\bin
    java.runtime.name=Java(TM) SE Runtime Environment
    java.runtime.version=1.8.0_66-b17
    java.specification.name=Java Platform API Specification
    java.specification.vendor=Oracle Corporation
    java.specification.version=1.8
    java.vendor=Oracle Corporation
    java.vendor.url=http://java.oracle.com/
    java.vendor.url.bug=http://bugreport.sun.com/bugreport/
    java.version=1.8.0_66
    java.vm.info=mixed mode
    java.vm.name=Java HotSpot(TM) 64-Bit Server VM
    java.vm.specification.name=Java Virtual Machine Specification
    java.vm.specification.vendor=Oracle Corporation
    java.vm.specification.version=1.8
    java.vm.vendor=Oracle Corporation
    java.vm.version=25.66-b17
    line.separator=

    os.arch=amd64
    os.name=Windows 7
    os.version=6.1
    path.separator=;
    sun.arch.data.model=64
    sun.awt.enableExtraMouseButtons=true
    sun.boot.class.path=c:\program files\common files\i4j_jres\1.8.0_66\lib\resources.jar;c:\program files\common files\i4j_jres\1.8.0_66\lib\rt.jar;c:\program files\common files\i4j_jres\1.8.0_66\lib\sunrsasign.jar;c:\program files\common files\i4j_jres\1.8.0_66\lib\jsse.jar;c:\program files\common files\i4j_jres\1.8.0_66\lib\jce.jar;c:\program files\common files\i4j_jres\1.8.0_66\lib\charsets.jar;c:\program files\common files\i4j_jres\1.8.0_66\lib\jfr.jar;c:\program files\common files\i4j_jres\1.8.0_66\classes
    sun.boot.library.path=c:\program files\common files\i4j_jres\1.8.0_66\bin
    sun.cpu.endian=little
    sun.cpu.isalist=amd64
    sun.desktop=windows
    sun.io.unicode.encoding=UnicodeLittle
    sun.java.command=C:\Program Files\TripleA\TripleA.exe
    sun.jnu.encoding=Cp1252
    sun.management.compiler=HotSpot 64-Bit Tiered Compilers
    sun.os.patch.level=Service Pack 1
    user.country=US
    user.dir=C:\Program Files\TripleA
    user.home=C:\Users\j
    user.language=en
    user.name=j
    user.script=
    user.timezone=America/Los_Angeles
    user.variant=



  • So I need to remove JAVA, and do a fresh new/complete install?


  • Moderators Admin

    @Gargantua
    Please browse to

    c:\program files\common files\i4j_jres\
    

    and delete the folder "i4j_jres" and its subfolders manually.
    It is the here included old Java 1.8.0_66 that causes your trouble.

    Then try to use the dice server again.
    If it still doesn't work please reinstall Java 8 update 211 using the Windows Control Panel.


  • Admin

    Props to you @Panther you're getting really good at troubleshooting common issues 👍
    Couldn't have done it any better


  • Moderators Admin

    @RoiEX Thank you! I have learnt a lot from you, @redrum , @ssoloff and @LaFayette throughout the years. You always have an open ear and explain issues in an understandable way giving interesting background information. 🙂



  • Panther,

    Thanks for pointing that folder out. I simply renamed it, and then installed the Java 8 211. Everything appears to be working now!


Log in to reply