Error on 17301


  • Moderators

    battle didn't work correctly when prompt showed up. I'll try and add a save and some more info, but when I did the report to triplea thing it didn't work.

    Screenshot from 2019-12-25 03-18-01.png

    here's save 17301 error.tsvg

    so the error threw as soon as the last battle started. While I was trying to follow the prompt for the bug report to triplea, it eventually concluded the battle on it's own. I checked history and it shows no info on the error so...idk

    Yea so the battle windows were blank. i assume they were asking if I wanted to submerge since it was all subs attacking.


  • Moderators

    A save before combat

    17301 error test.tsvg

    It nutted up twice more in different spots. It seems the "battle window" was part of the problem idk. Multiple windows show up over each other with the main one still battling but real slow. Kinda hard to tell.

    Anyway it ain't working right 🙂

    Edit
    Hmm...can't replicate with the oob G40 game. Seems odd it would be xml specific but I suppose it's possible. I mean it works on 13066 so it doesn't seem as if that should matter.


  • Admin

    @beelee this looks to be a similar description as: https://github.com/triplea-game/triplea/issues/5010

    I tried saving the posted save game at combat and was not able to hit the problem: test-save.tsvg

    1. The issue seems like it is not consistent.
    2. The problem is probably rule specific, but it's generic it seems to submerge/retreat, so it probably impacts almost all maps

    @beelee do you remember if you fought the battles in any specific ordering? Are you able to hit the problem at all again?

    This problem is the biggest one we have in the latest pre-release, as soon as it is fixed we'll likely be able to issue a new release shortly afterwards.


  • Moderators

    @LaFayette
    yea I tried to do everything the same to reproduce it but can't swear it was 100% the same. Over 90 easily fwtiw. I'll try some more while saving before combat.


Log in to reply