Can't Get Politics Phase to Work on Map



  • I can't seem to get the politics phase of my map to work. I copied all the politics language directly from Global 1940 -balanced. (And "use politics" property is set to true). But when i play the map, it goes straight from purchase to combat. (No option to change relationships, etc.). Here is an example of one the political actions in the xml. Any thoughts?

    <attachment name="politicalActionAttachment_Axis_To_War_With_TrueNeutrals" attachTo="Germans" javaClass="games.strategy.triplea.attachments.PoliticalActionAttachment" type="player">
    <option name="conditions" value="conditionAttachment_Germans_Not_Yet_At_War_With_TrueNeutrals"/>
    <option name="relationshipChange" value="Germans:Neutral_True:War"/>
    <option name="relationshipChange" value="Italians:Neutral_True:War"/>
    <option name="relationshipChange" value="Japanese:Neutral_True:War"/>
    <option name="relationshipChange" value="Neutral_True:British:Friendly_Neutral"/>
    <option name="relationshipChange" value="Neutral_True:UK_Pacific:Friendly_Neutral"/>
    <option name="relationshipChange" value="Neutral_True:ANZAC:Friendly_Neutral"/>
    <option name="relationshipChange" value="Neutral_True:Dutch:Friendly_Neutral"/>
    <option name="relationshipChange" value="Neutral_True:Chinese:Friendly_Neutral"/>
    <option name="relationshipChange" value="Neutral_True:French:Friendly_Neutral"/>
    <option name="relationshipChange" value="Neutral_True:Neutral_Allies:Friendly_Neutral"/>
    <!-- Axis declaring war on Strict Neutrals also flips Mongolia -->
    <option name="relationshipChange" value="Germans:Mongolians:War"/>
    <option name="relationshipChange" value="Italians:Mongolians:War"/>
    <option name="relationshipChange" value="Japanese:Mongolians:War"/>
    <option name="relationshipChange" value="Mongolians:British:Friendly_Neutral"/>
    <option name="relationshipChange" value="Mongolians:UK_Pacific:Friendly_Neutral"/>
    <option name="relationshipChange" value="Mongolians:ANZAC:Friendly_Neutral"/>
    <option name="relationshipChange" value="Mongolians:Dutch:Friendly_Neutral"/>
    <option name="relationshipChange" value="Mongolians:Chinese:Friendly_Neutral"/>
    <option name="relationshipChange" value="Mongolians:French:Friendly_Neutral"/>
    <option name="relationshipChange" value="Mongolians:Neutral_Allies:Friendly_Neutral"/>
    <option name="text" value="Axis_War_Neutral_True_Mongolians"/>
    </attachment>


  • Moderators Admin

    @Joe-G What is the <option name="conditions" value="conditionAttachment_Germans_Not_Yet_At_War_With_TrueNeutrals"/> saying? My best guess is check that one returns true. Also you probably need to check you have the relationshipInitialize correctly defined (so that the Germans have that relationship that is checked by the condition).



  • @Cernel hey thanks for ur reply.

    Here is the condition you asked about: <attachment name="conditionAttachment_Germans_Not_Yet_At_War_With_TrueNeutrals" attachTo="Germans" javaClass="games.strategy.triplea.attachments.RulesAttachment" type="player">
    <option name="relationship" value="Germans:Neutral_True:anyNeutral"/>
    </attachment>



  • Hey Cernel, thanks for your guidance here. I figured out the problem.

    1. Did not have a relationshipinitialize section
    2. Did not have any true neutral territories on the board so it interfered with stuff.

    It works now!

    Thanks for all your help.


Log in to reply
 

42300
2047
2288
Who's Online
Visitors Today