Stuck password with 2.0.19993



  • I've installed the pre-release of 2.0.19993.

    I happened to get my password to the A&A-forum wrong and now the client insists on it always. I've re-installed, but doesn't work.

    Is there a way to clean out the stored password, and if so, how?


  • Admin

    You should be able to go to your "Engine Preferences" > "Play by Forum/Email" and correct your password



  • @RoiEX said in Stuck password with 2.0.19993:

    You should be able to go to your "Engine Preferences" > "Play by Forum/Email" and correct your password

    Thanks! I'll try that.



  • @RoiEX said in Stuck password with 2.0.19993:

    You should be able to go to your "Engine Preferences" > "Play by Forum/Email" and correct your password

    It didn't work at first, but after resetting it and saving I could save the new password properly. I'll see, but atleast it seems that way now.



  • I'm sorry to say that it still is stuck with the old password. Amazingly. Think perhaps it's time for me to file a bug-report. Where should that suitable?


  • Admin

    Well in any case the "Reset to Default" button should work to reset all settings completely.
    If that doesn't work for some reason, please post the exact steps to start PbF you're performing



  • @RoiEX said in Stuck password with 2.0.19993:

    Well in any case the "Reset to Default" button should work to reset all settings completely.
    If that doesn't work for some reason, please post the exact steps to start PbF you're performing

    I've tried it, and now I've tried it several more times. Doesn't work.

    I don't understand the request.

    I open the client. I click PBF. I load the game. Have tried to reverse those two, to no avail. Always just gets the wrong password. I've corrected the password and opened the game, saved. Doesn't matter.

    It's not a critical bug (if that's what it is) at all, but very annoying.

    Is there anyway I can clean out the client's cache?


  • Admin

    There is of course a way to clear out the cache manually but I highly doubt that's the actual problem because clicking reset to default should do exactly that. (It should also give you a prompt in case any values got updated by this).

    So I'm wondering: How do you tell it's using 'the old' password? And you're not just using the wrong password entirely?

    The reason I asked for your steps: Before starting PbF, there should be a username and password field which can temporarily override the settings IIRC. So it shouldn't matter at all if some password happens to be cached regardless



  • It's very evident.

    When I first started using 2.0 I filled in the wrong password. It's a different length than my correct one. By one letter.

    When I start the client, the credentials are always empty.

    When I load a game, the credentials show up. And it's always 7 instead of 6 dots in the password-field.

    I adjust this manually. Every time. If I don't, I can't make game posts. When I do I can.

    There's a 100 % conclusion that the client is stuck with a wrong password, which I'm simply not able to correct, except by manual input every single time I load or start a game.



  • And I've, as above stated, tried all different functions regarding resetting. The client couldn't care less about my sincere efforts.

    I claim this is a bug.



  • I've also re-installed the client, to no avail.

    I'd prefer not to have to re-install the operative system of my computer only to fix this. If possible.



  • Apart from this, I love the 2.0 and the new features! Just want to make that clear. 🙂



  • Just to add my $0.02. I'm playing the game with @trulpen and I have the same problem. I have to test post prior to starting the game to check that my password has been entered correctly--every time I play the game. I have checked "remember Password" but to no avail.


  • Admin

    If you want to go the manual route (assuming you're using windows), pleaso download this zip and unzip it: Reset-Password.zip
    It contains a file you should be able to double click, and confirm a dialog that pops up.
    This should remove any stored A&A Forum password altogether.

    If you think the "remember password" feature doesn't work all for you you can consider submitting a bug report: https://forums.triplea-game.org/topic/1708/how-to-submit-a-bug-report
    Maybe there's a real bug involved somewhere, but I find this unlikely since we haven't touched this mechanism in a while now and nobody had any notable issues with it. (At least none were reported)



  • @RoiEX Thanks. But I'm using Linux. Any difference in fixing this?


  • Admin

    Have a look at the /etc/.java or ~/.java/.userPrefs folders. It should be stored somewhere in there.
    Just do a recursive grep for "FORUM" and you should be able to find it
    The password itself is encrypted, so it'll look like a bunch of garbage letters



  • Ok, found in .userPrefs/games/strategy/settings/prefs.xml. I suppose I just delete the offending lines, and the game should regenerate the appropriate entries.

    Question: could part of the problem be that we have 2 versions of the game running? I need the old version for games that I was previously playing.



  • @Jim-Parker said in Stuck password with 2.0.19993:

    .userPrefs/games/strategy/settings/prefs.xml.

    .userPrefs/games/strategy/triplea/settings/prefs.xml.



  • I don't know how this happens... But I deleted the lines from prefs.xml, and loaded a previous game.
    As expected, the username and password fields were blank. I entered new info, and successfully posted.

    Then, I saved the game, closed the program and restarted, reloaded the new game, and magically...the bad password had populated the password field again.

    Obviously, I could not read it, but it had 8 characters (same length as old password) vice the 10 character password that is new.


  • Admin

    That's definitely odd.
    I'll try to come up with a way how to dig further into this


Log in to reply