Help: National Objectives are removed when editing name of map file

  • Moderators Admin


    Now the current problem is that when using the ingame downloader the folder


    is zipped under


    So there is an incorrect structure:


    I have currently no idea where this subordinate "world_war-ii_v3_1941_balanced_mod" derives from.

    This is causing the problem. Your repo and XML seem to be fine now.

  • I have currently no ides where this subordinate "world_war-ii_v3_1941_balanced_mod" dervives from.
    This is causing the problem.

    OK, well, I agree. Who would know the answer to that question?

  • @Cernel

    Thank you; that information is in the format I am looking for, but it was not successful. I uninstalled tripleA, deleted my entire downloadedMaps folder as well the folder above that with the options.cache, and reinstalled and downloaded everything from scratch and got the same error.

    I believe the problem is as Panther said: the folder name is wrong in the zip, but I don't know what sets the folder name for the zip or how to change it.

  • Moderators Admin


    This is how it should look like:


  • OK, that's fine, but I don't know how to cause TripleA to rename that folder when a user downloads the map from TripleA. Who would know that?

  • Moderators Admin


    No idea at this moment, sorry. I have just checked the yaml and your repo - that looks all fine.
    I have never seen this before.

    Let's hope that a developer has an idea - or that one of us has an idea when thinking further about it...

  • Moderators Admin

    @Jason-Green-Lowe I'm not seeing anything by which that may be expected to happen. I suggest opening a problem report.

    I suggest you don't make any more changes until someone get back to you there. The only unusual thing I see is that you are using the image of another map repository for download list display.

  • Moderators Admin

    @Cernel said in Help: National Objectives are removed when editing name of map file:

    The only unusual thing I see is that you are using the image of another map repository for download list display.

    As I said, I believe it should not be related to any actual problem, but you should change the current 2174
    line in

    Probably whoever merged your pull request overlooked it or it would have asked you the same.

  • Moderators Admin

    Thinking about it some more, I assume that the main folder name is generated from the "mapName" in the, by making it all lowercase and substituting spaces with underscores.

    So, in your case, if I'm guessing right, you should change line 2170 from:
    - mapName: World War II v3 1941 Balanced Mod
    - mapName: 1941BalancedMod.


    Change your repository name and the "mapName" property value inside the game file to world_war_ii_v3_1941_balanced_mod.
    Change line 2172 from:

    Regardless, I believe the way you are going is at least unpolished. The map name that is shown to users in the moment they download should be fundamentally the same as the actual name of the map, as specified in the mapName property. Having one as "World War II v3 1941 Balanced Mod" and the other one as "1941balancedmod" seems inconsistent to me, regardless of any problems (just my opinion, as I don't actually know if there are rules about map naming documented anywhere and I guess what you proposed was considered good enough, since your changes have been merged, thus accepted).

    Between the alternatives I'm suggesting, especially to clarify this map is derived from v3 (instead of v6 or something else), I advise for the second one.

  • Admin

    The way the game engine finds Map XML from map name is a shit show. I'm sorry it's still the case and has not been updated to be something more reasonable.

    @Jason-Green-Lowe the map should be working now, I did some testing and downloaded it. The missing piece is that the map-name option, the repository name, and the name in triplea-maps.yaml all need to line up. The triplea-maps.yaml name can have upper case letters and spaces instead of underscores, but otherwise it needs to match the repository name which then needs to match the XML 'mapName' property.

    To get things working I renamed both the repository and the 'mapName' properties to "world_war_ii_v3_1941_balanced_mod"

  • Wonderful! It works now on my end -- thank you so much for fixing the problem. 🙂

Log in to reply