64 Bit & Downloading Maps Issue

  • My previous computer I was able to download the 32 bit version with maps; now that I have a new 64 bit computer I have attempted to download TripleA and several maps but keep getting the following errors (no matter what map I download):

    Could not parse map file correctly, would you like to remove it?

    Does anyone have suggestions and help which they can provide with resolving this so I can get back to gameplay?

  • Admin

    @misc23 I'd delete all your maps from your maps folder and try re-downloading them to start. If that doesn't solve it then can you post what version of TripleA you installed or trying re-installing with the latest download.

  • @redrum I've deleted all the maps and tried re-downloading them to no avail. Addition I have removed and re-installed TripleA and it still hasn't worked.

    I have a HP Zbook with Windows 64 Bit. I have tried to install the latest version of TripleA which was released on Nov. 25th:

    Any additional ideas or suggestions?

  • Admin

    @misc23 Hmm. Do you get any other details in an error popup when you see that message?

    If not then in order to figure out what's going on, I need more information. Can you do the following and post results in this thread:

    1. Open TripleA
    2. Go to Engine Preferences
    3. Go to Folder tab
    4. Post your maps folder path here
    5. Open Windows File Explorer and navigate to that path
    6. Post a screenshot of the maps in that folder

  • Moderators Admin

    @redrum Actually I have had this issue yesterday after installing a new (used) hard drive yesterday. Occurred for v3 41 and TWW and a few other maps. For most it did not. For those ones I just took them from the repo on git hub and it worked that way.

  • Moderators Admin

    @prastle https://github.com/triplea-maps Try installing it this way and drag and drop to your downloaded maps folder in user @MiSC23

  • Admin

    @prastle Oh really? That's kind of concerning if maps downloaded through TripleA are showing errors.

  • Moderators Admin

    @redrum @ the time I thought it was due to the size of the file and my hard drive failing. Apparently others have had same error appear.

    The map downloads correctly and then installs correctly or appears to. After closing the download maps page and attempting to load the map to play it (I also tried an offline game) The engine states in a small box as he said.

    "Could not parse map file correctly, would you like to remove it?" with a yes or no response. Interestingly if you choose no it actually doesn't remove the file. I had to delete it and overwrite from GitHub repo. First time I have ever seen this and it did not do it for all maps.

  • Moderators Admin

    @redrum New hard drives! 0 Problems! So perhaps he has a hard drive on the crapper as as well?

  • Admin

    The only thing that's changed in this area recently was parallelization of map processing. However, that code looks pretty safe to run concurrently.

    It would be interesting to see if the map .zip files are really corrupt or if this is caused by code. @MiSC23, could you please attach one of the (smaller) map .zip files with which you are seeing this error?

  • @prastle I have a new computer, so its not the hard drive which is the error. The errors I receive are through downloading maps through TripleA.

    @redrum I cannot upload the maps causing problems as the files are too big here-Europe, Pacific, and Global are the ones that I'm struggling with. I've tried deleting all files and re-downloading them and that has not made any difference.

    Followed steps you outlined in several previous messages:

    Maps Folder: C:\Users\mcrew\triplea\downloadedMaps

    Attached Screen Shot here.0_1514325604636_2017-12-26.png

  • @ssoloff [0_1514339176047_pacific_1942-master.zip](Uploading 4%) which is approx 1,700 kb but receive an error that the entity file is too big. Is there another method to get you the info you need?

    It seems it does not matter whether I download directly from GitHub or triplea certain maps have the same error that I encountered when I started this thread. In particular: Europe, Pacific, Civil War, Cold War, Star Trek...

  • Moderators

    the smart people will get back to you soon but you might try deleting everything and starting over. Install java first, then triplea. There is a issue for some users that do triplea first.

    Doubt this is your problem, but you could try it.

  • Moderators Admin

    @misc23 What I found was
    the new installer auto installed 32 bit

    rec u install java on clean system or confirm you have newest java
    then install triplea
    but yes 64 bit caused me probs

    try the new

  • Admin

    The issue with file uploads can be fixed rather simple: Our server has limited disk space, so we require users to upload large files to public clouds. There's stuff like Google Drive or Dropbox where you need an account to store files, but there are also temporary file hosters where you don't need to have any account but the files are being deleted after a set amount of time.
    Based on your description of the problem it seems to be rather system specific and not a general problem of TripleA, so I'd assume the map file is probably going to be fine, I'd still recommended to upload it to somewhere.
    In order to figure out what your specific issue is: Could you post the exact error message?
    Is there just a small window telling you something went wrong or does the actual error console with a detailed description pop up?

  • Moderators Admin

    @roiex test upload![0_1514390498186_th[1].jpg](Uploading 100%)

  • Moderators Admin

    @prastle ![0_1514390681802_th[1].jpg](Uploading 100%)

  • @prastle: I have confirmed that I have the latest version of Java. I removed the prior version of TripleA, restarted the computer, and then used the GitHub link to download the 64 bit version. Some more of the maps downloaded correctly this time (than before) but there were several maps did not download again: WWII Pacific, Feudal Japan, Star Trek, Star Wars, etc.

  • Moderators Admin

    @misc23 Two separate issues
    the downloader
    uploads here
    btw my uploads failed as well
    Rec you try to uninstall the maps in ?
    with the downloader
    and reinstall

  • Moderators Admin

    @misc23 also s @RoiEX showed me elsewhere
    you might still be running 32 bit in background


    this should not affect downloads

Log in to reply