64 Bit & Downloading Maps Issue



  • My previous computer I was able to download the 32 bit version with maps; now that I have a new 64 bit computer I have attempted to download TripleA and several maps but keep getting the following errors (no matter what map I download):

    Could not parse map file correctly, would you like to remove it?

    Does anyone have suggestions and help which they can provide with resolving this so I can get back to gameplay?


  • Admin

    @misc23 I'd delete all your maps from your maps folder and try re-downloading them to start. If that doesn't solve it then can you post what version of TripleA you installed or trying re-installing with the latest download.



  • @redrum I've deleted all the maps and tried re-downloading them to no avail. Addition I have removed and re-installed TripleA and it still hasn't worked.

    I have a HP Zbook with Windows 64 Bit. I have tried to install the latest version of TripleA which was released on Nov. 25th: 1.9.0.0.7621.

    Any additional ideas or suggestions?


  • Admin

    @misc23 Hmm. Do you get any other details in an error popup when you see that message?

    If not then in order to figure out what's going on, I need more information. Can you do the following and post results in this thread:

    1. Open TripleA
    2. Go to Engine Preferences
    3. Go to Folder tab
    4. Post your maps folder path here
    5. Open Windows File Explorer and navigate to that path
    6. Post a screenshot of the maps in that folder

  • Admin

    @redrum Actually I have had this issue yesterday after installing a new (used) hard drive yesterday. Occurred for v3 41 and TWW and a few other maps. For most it did not. For those ones I just took them from the repo on git hub and it worked that way.


  • Admin

    @prastle https://github.com/triplea-maps Try installing it this way and drag and drop to your downloaded maps folder in user @MiSC23


  • Admin

    @prastle Oh really? That's kind of concerning if maps downloaded through TripleA are showing errors.


  • Admin

    @redrum @ the time I thought it was due to the size of the file and my hard drive failing. Apparently others have had same error appear.

    The map downloads correctly and then installs correctly or appears to. After closing the download maps page and attempting to load the map to play it (I also tried an offline game) The engine states in a small box as he said.

    "Could not parse map file correctly, would you like to remove it?" with a yes or no response. Interestingly if you choose no it actually doesn't remove the file. I had to delete it and overwrite from GitHub repo. First time I have ever seen this and it did not do it for all maps.


  • Admin

    @redrum New hard drives! 0 Problems! So perhaps he has a hard drive on the crapper as as well?
    @MiSC23


  • Global Moderator

    The only thing that's changed in this area recently was parallelization of map processing. However, that code looks pretty safe to run concurrently.

    It would be interesting to see if the map .zip files are really corrupt or if this is caused by code. @MiSC23, could you please attach one of the (smaller) map .zip files with which you are seeing this error?


Log in to reply
 

Looks like your connection to TripleA Forum was lost, please wait while we try to reconnect.