Error loading my new(ish) map



  • I am getting this error when trying to select the map I am working on. I cant find any sort of error log to look deeper in. I feel like i have had this happen before too.

    Could not parse: jar:file:/C:/Users/ckimb/triplea/downloadedMaps/XCOM-master.zip!/XCOM-master/map/games/xcom.xml  GameParseException: 
    
    failed to parse XML document
    

    edit: could missing unit icons do anything at this point?



  • @ff03k64

    I don't think this has anything to do with unit images. The error is saying that the xml itself is not being parsed (read properly by the TripleA engine). It hard to say what is causing this with so little information to go on.

    Sorry.

    Cheers...



  • Isn't there a log file anywhere that can say where the parsing breaks? I feel like when i was working on this map previously, there was more to logs than one line that i got this time.


  • Admin

    The error message would ideally be much better, this is kinda poor on the TripleA engine part.

    Try running the XML through a validator, it might be able to give you an idea where the problem is:
    https://www.xmlvalidation.com/

    If you still can't find the error in the validator, try commenting out large blocks of the XML and re-validating until you have a valid XML. Then uncomment blocks until you find the part that is giving the validation error.



  • @ff03k64

    Also you may try posting it here. Maybe some fresh eyes could spot the problem.

    Cheers...



  • Thanks for the suggestions so far. First off, I commented out a bunch of new stuff. Didn't work, figured i missed some. I managed to find a previous version that works. I compared the two, and I think i managed to comment out anything that was different. Still didn't work, even though the old one did.

    My files are here.

    edit:better link



  • Some new errors. 26 of the following. 26 of the relief tiles are not showing up on the map.

    Aug 08, 2020 3:55:15 PM org.triplea.game.client.HeadedGameRunner lambda$initializeClientSettingAndLogging$0
    SEVERE: null
    java.util.NoSuchElementException
    	at com.google.common.collect.AbstractIndexedListIterator.next(AbstractIndexedListIterator.java:75)
    	at games.strategy.triplea.ui.mapdata.DefaultColors.nextColor(DefaultColors.java:30)
    	at games.strategy.triplea.ui.mapdata.MapData.getPlayerColor(MapData.java:496)
    	at games.strategy.triplea.ui.screen.drawable.LandTerritoryDrawable.draw(LandTerritoryDrawable.java:45)
    	at games.strategy.triplea.ui.screen.drawable.LandTerritoryDrawable.draw(LandTerritoryDrawable.java:29)
    	at games.strategy.triplea.ui.screen.Tile.draw(Tile.java:69)
    	at games.strategy.triplea.ui.screen.Tile.drawImage(Tile.java:54)
    	at games.strategy.triplea.ui.panels.map.MapPanel.lambda$paint$7(MapPanel.java:745)
    	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
    	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
    	at java.base/java.lang.Thread.run(Thread.java:834)
    

    edit: one of those 26 was slightly different.

    Aug 08, 2020 3:53:54 PM org.triplea.game.client.HeadedGameRunner lambda$initializeClientSettingAndLogging$0
    SEVERE: null
    java.util.NoSuchElementException
    	at com.google.common.collect.AbstractIndexedListIterator.next(AbstractIndexedListIterator.java:75)
    	at games.strategy.triplea.ui.mapdata.DefaultColors.nextColor(DefaultColors.java:30)
    	at games.strategy.triplea.ui.mapdata.MapData.getPlayerColor(MapData.java:496)
    	at games.strategy.triplea.ui.screen.drawable.LandTerritoryDrawable.draw(LandTerritoryDrawable.java:45)
    	at games.strategy.triplea.ui.screen.SmallMapImageManager.updateTerritoryOwner(SmallMapImageManager.java:80)
    	at games.strategy.triplea.ui.panels.map.MapPanel.initSmallMap(MapPanel.java:845)
    	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
    	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
    	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
    	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
    	at java.base/java.security.AccessController.doPrivileged(Native Method)
    	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
    	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
    	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
    	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
    	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
    	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
    	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
    	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
    


  • @ff03k64

    Checked your files and found a lot of hanging '--' within the comments. This is throwing your errors. Also a few '<!--' starters in some comments.

    On the main screen, select 'Engine Preferences', then select the 'Game' tab. Third option down 'Show Console' set to true. This will give you better error messages in the console window!

    Don't worry I tend to make my comments with '<!--- --->' one to many dashes on each side. It happens!

    Cheers...



  • Ah, i figured that since they were inside of a comment, it wouldn't matter. Thanks!

    With regards to the console, I wasn't getting into the game at all, so that is why i couldn't find it. Thanks!



  • @LaFayette I think one of my posts got lost. I tried the validator, but it needed game.dtd to try to run. I couldn't find it.



  • @ff03k64 Check this post for how to find the game.dtd

    I suggest using an editor that specifically supports xml. I use XML Copy Editor.


Log in to reply