Anyone having trouble with 11440 ?


  • Donators

    I get a error when I try to run the game :

    0_1534662801529_Screenshot from 2018-08-19 02-09-56.png

    here's the last couple lines:
    0_1534662868606_Screenshot from 2018-08-19 02-10-24.png

    Works on 10876

    seems that it doesn't like the mobile_artillery unit. Has always worked before though


  • Donators Moderators Admin

    @beelee You have an extra ":" after "mech_ infantry" for one in the support attachment in question. But that should error in any version I would think. But try removing it anyways.


  • Admin

    @beelee We recently made a change to how strings that contain multiple values separated by a colon (":") are parsed. I think @General_Zod identified the problem correctly. Prior to 11440, the engine would ignore the trailing colon, but in 11440 and later, it thinks there's an empty token at the end of the overall value.

    Since Global 40 House Rules is an experimental map, removing the trailing colon is probably the best solution. It will still be compatible with engines prior to 11440.

    However, there could be other maps that have the same problem. In which case, we would probably have to change the engine back to using the old parsing code that ignores trailing colons, at least until we can update all those maps. I will try to search all the triplea-maps repos for any other trailing colons to see how prevalent the problem is.


  • Admin

    Below are the maps that have an option value ending with a colon. There are only 13 instances, with eight of them being in one of the Global 40 House Rules variants.

    I'd be interested in hearing from other devs and map makers if the map XMLs should be fixed or if the colon parsing change in the engine should be reverted. (Note that I don't know if all 13 instances cause parser errors; for sure the unitType options are a problem.)

    age_of_tribes/map/games/Age_of_Tribes_Classical.xml:12908:            <option name="players" value="Baltic:Germanic:Brittonic:Celtic:Romanic:Hellenic:Slavic:Hattic:Diseases:"/>
    domination_1914_blood_and_steel/map/games/Domination_1914_Blood_And_Steel.xml:6470:      <option name="placement" value="St. Petersburg:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:infantry:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:gas:"/>
    invasion_usa/map/games/Invasion_USA.xml:18165:			<option name="conditions" value="conditionAttachmentMoreMinneapolisMobilizes:conditionAttachmentAddToAmericanPurchase:conditionAttachmentAmericanMinneapolisOwnership:"/>
    pacific_challenge/map/games/Pacific_Theater_Solo_Challenge.xml:6989:      <option name="conditions" value="conditionAttachmentUsaBomberUpgrade:"/>
    pacific_challenge/map/games/Pacific_Theater_Solo_Challenge.xml:7447:      <option name="conditions" value="conditionAttachmentAllBomberUpgrade:"/>
    global_40_house_rules/map/games/Global_40_House_Rules.xml:5455:      <option name="unitType" value="infantry:mech_infantry:"/>
    global_40_house_rules/map/games/Global_40_House_Rules.xml:9052:      <option name="directPresenceTerritories" value="Normandy Bordeaux:" count="1"/>
    global_40_house_rules/map/games/Global_40_House_Rules_Canada.xml:5553:      <option name="unitType" value="infantry:mech_infantry:"/>
    global_40_house_rules/map/games/Global_40_House_Rules_Canada.xml:9745:      <option name="directPresenceTerritories" value="Normandy Bordeaux:" count="1"/>
    global_1940_redesign_house_rules/map/games/Global_40_HouseRules.xml:5585:      <option name="unitType" value="infantry:mech_infantry:"/>
    global_1940_redesign_house_rules/map/games/Global_40_HouseRules.xml:8520:      <option name="directPresenceTerritories" value="Normandy Bordeaux:" count="1"/>
    global_1940_redesign_house_rules/map/games/Global_40_HouseRules_Canada.xml:5485:      <option name="unitType" value="infantry:mech_infantry:"/>
    global_1940_redesign_house_rules/map/games/Global_40_HouseRules_Canada.xml:8789:      <option name="directPresenceTerritories" value="Normandy Bordeaux:" count="1"/>
    

  • Donators

    @ssoloff
    I think that you are right, and the extra colon should be removed. I will get to Invasion USA.

    Thanks for all your effort.

    Cheers...


  • Donators

    @General_Zod Thanks for the replies everyone. Should be a easy fix 🙂


  • Donators

    @beelee @ all yes just fixed. Thanks again everyone


  • Admin

    I better also remove the : from Age of Tribes. I will get around to do it later this week 🙂


  • Admin

    Another thing regarding that specific pre release version of TripleA: I just installed it yesterday and have just tried it out once. But I experienced something I have not seen before:

    When I had my MS Office Word 2007 program open, and typing text in an open docx file, while I had an on going TripleA map/game minimized in the background (and also when it was in window mode), unit tooltips from the map frequently popped up in the mouse cursor's location when I was text typing. Meaning that even as Word was in full screen and the cursor was over a random location of the white text field in Word, tooltips would pop up!? Very strange. And the TripleA map and unit was probably not located just behind the Word window, so one can not say that the mouse just ignored the Word window. Because every time I moved the cursor, a tooltip would again pop up. 🤔

    Have anyone else ever experienced this?
    If it means anything, I just updated java before this.


  • Admin

    @frostion Its a bug. I think I noticed something similar. Its because the new hover over unit tooltips were added and I think it has something to do with they will appear even if TripleA isn't the current focused window.


  • Donators Moderators Admin

    @frostion Yes this happens on my system as well... the tooltip shows through on my screen even though a different application is in the foreground. I am on .11131