”Failed to read file at:…” when trying to download maps


  • Admin

    I can’t startup and use the download maps feature anymore. When I in TripleA’s main menu choose and press the “Download Maps”, this screen pops up and the selection tabs have no content. I can’t download anything. Here is what I see.
    Unavngivet.png

    This is the error one can read from the “Show details” button:

    jan. 25, 2019 11:37:09 PM games.strategy.engine.framework.map.download.DownloadRunnable readLocalFile
    SEVERE: Failed to read file at: C:\Games\TripleA
    java.nio.file.AccessDeniedException: 
    	at sun.nio.fs.WindowsException.translateToIOException(Unknown Source)
    	at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
    	at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
    	at sun.nio.fs.WindowsFileSystemProvider.newByteChannel(Unknown Source)
    	at java.nio.file.Files.newByteChannel(Unknown Source)
    	at java.nio.file.Files.newByteChannel(Unknown Source)
    	at java.nio.file.Files.readAllBytes(Unknown Source)
    	at games.strategy.engine.framework.map.download.DownloadRunnable.readLocalFile(DownloadRunnable.java:56)
    	at games.strategy.engine.framework.map.download.DownloadRunnable.getDownloads(DownloadRunnable.java:33)
    	at games.strategy.engine.ClientContext.getMapDownloadList(ClientContext.java:67)
    	at games.strategy.engine.framework.ui.background.BackgroundTaskRunner$1.doInBackground(BackgroundTaskRunner.java:129)
    	at javax.swing.SwingWorker$1.call(Unknown Source)
    	at java.util.concurrent.FutureTask.run(Unknown Source)
    	at javax.swing.SwingWorker.run(Unknown Source)
    	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    	at java.lang.Thread.run(Unknown Source)
    

    Does anyone see what it wrong?


  • Admin

    PS: C:\Games\TripleA is of course my TripleA install folder.


  • Admin

    Are you using 1.9?


  • Admin

    You should clear this setting and it should work again:
    2e02c007-ad84-4be9-85e5-d19b8f99d72f-grafik.png


  • Admin

    Thanks @RoiEX for the response. I can now download again.

    I used engine v1.10, so the setting was not where you showed it to be. But I found it in another fan.

    Unavngivet.png


  • Admin

    @Frostion The location didn't change.
    It's only my mouse that hovered over the second tab,so that's why both tabs are highlighted.


  • Admin

    Ahhhaa ... Now it all makes more sense 😊


Log in to reply