[Fixed] Could be bug



  • Since the latest update i cannot get through a game without this happening. At some point in the game it will freeze and the error message that shows up on the side screen says something like cannot continue until you finish the battle in (whatever territory was the last fight in the previous turn). So for example say a battle occurred in Serbia at the end of the last turn in any game and it is now the next players turn as soon as any fight anywhere starts that error occurs and says you need to finish the battle in Serbia first. Even though in the previous turn the fight was indeed completed or it would not have advanced into the next turn. I wish i had a copy of the error message but every time this happens it near locks up my computer and the only thing i can do is access task manager and shut the program down.


  • Donators

    @avshar
    Bummer. By latest update do you mean 13066 ? Is it the same map or different maps ?

    Maybe post a save the turn before it happens. Also what type of machine you're on and what java you're using.



  • @beelee Sorry no save, i erased it since it kept happening. If/when it happens again i will do that. System is laptop AMD 2.3 ghz with 6gb ram running windows 8. Java is current at java 8. It happens on all maps and yes its 13066.


  • Donators

    @avshar
    hmm...for some reason I think I remember seeing this before. Not sure though. I think Panther was involved with the solution.

    Lets ask him. @Panther have you encountered this problem since 13066 came out ?


  • Moderators Admin

    @beelee I remember this issue having occurred here and there: For example in
    https://forums.triplea-game.org/topic/919/bug-or-error-iron-war/1
    and it had been fixed, see
    https://github.com/triplea-game/triplea/issues/3377

    Personally I have never experienced this issue at any time, so neither with 13066 nor with any pre-release.

    @avshar Do you experience this with a special map (which one?) or with every map? Also you might look into your autosaves to find and load an automated savegame that maybe enables you to reproduce the error.


  • Admin

    @avshar Interesting, definitely very odd. I need you to check a couple of things to find the root cause of this since as @Panther pointed out the other issue has already been fixed.

    1. Try out the latest pre-release. You can find a list of all versions here. Maybe your issue got fixed unintentionally already. Note that 1.10 versions are heavily incompatible with 1.9
    2. If the issue still isn't fixed I'd kindly ask you to try to identify the version introducing this issue has been introduced. It will be a tedious process, but it will make identifying the problem so much easier for us than just random guessing.
    3. My current guess is that the game simply gets a little bit resource hungry on your system even though 6GB of ram should be sufficient. Could you check if this is actually the case? Try opening Task Manager just before you start the game and keep an eye on the memory consumption and CPU usage. When the game decides to throw an exception try creating a Screenshot (or create a photo of the screen using any camera if this doesn't work) and post it here. Maybe terminating a couple of processes before launching helps already.


  • @RoiEX Actually I seem to have found the problem. I had this game on a different system and forgot that system was a 32 bit system and this is a 64. So when I copied it over it seemed to conflict. As soon as I erased it and downloaded the 64 bit version its not happening. Thank you all for your input.


Log in to reply