Trouble Updating Map


  • Donators

    Updated "Oztea 1939 Global" under "Experimental" to 1.4 and the map works correctly but it keeps throwing a "missing image" error.

    Nov 09, 2019 1:38:40 AM games.strategy.util.LocalizeHtml localizeImgLinksInHtml
    SEVERE: Could not find: oztea_1939_global/doc/images/Neutral_Navy.png
    Nov 09, 2019 1:38:40 AM games.strategy.util.LocalizeHtml localizeImgLinksInHtml
    SEVERE: Could not find: oztea_1939_global/doc/images/Neutral_Navy.png

    The image is in "map/units/Neutral_True". It's the same as "Charles de Gaulle 1939" map but it doesn't throw the error.

    One needs to activate map option "Charles de Gaulle Neutrals Modified" for the image to show up in game, which it's supposed to do. Then Click past German tech phase and the image Neutral_Navy.png will show up same as de Gaulle game.

    Anyway, I been battling this all night and can't figure it out. Any help is appreciated.

    Thanks

    And the game works fine if you ignore it. It only shows up at game start.
    Also i don't remember seeing the beginning of the error " games.strategy.util.LocalizeHtml localizeImgLinksInHtml" in other missing image errors before but maybe i just dont remember correctly.


  • Moderators Admin

    @beelee The error is caused by a reference to the folder

    oztea_1939_global/doc/images/Neutral_Navy.png
    

    that does not exist inside the map-structure.

    Do you remember how that reference might have been included?


  • Donators

    @Panther

    Thanks for the reply Panther.

    Well I did it a lot of different ways. I have the image on my desktop and just slid it into where it needed to go. I also did the same thing from the "de Gaulle" game. They look the same and are named the same in both maps. Maybe I should try adding it from de Gaulles to Oz again.

    I'm thinking /doc/ isn't what we want ? I had trouble with git too. Usually i just hit commit-a and it works but I was having to do git add map as well since I replace the whole map when I make a change.

    Anyway I'll mess with it some more.

    Thanks again


  • Moderators Admin

    @beelee
    I just realized that your filename of that specific unit is the only one starting with a capital. Maybe related?


  • Donators

    @Panther yea I thought of that too but it's just how it's named in the xml. I usually do that with all new units because I don't like the back and forth between upper and lower. There are others that are named upper and work.

    Deleted the image again and then drug it from de Gaulle map and same thing.

    Screenshot from 2019-11-09 03-06-11.png

    Screenshot from 2019-11-09 03-05-47.png

    So I'm not sure how it's doing it. Maybe I messed something up in the git repo. I'll go through that again


  • Donators

    @beelee

    yea git seems to list upper case first and my system lists them alphabetically. Anyway the de gaulle map lists it the same way so hmm... i wouldn't think dragging the image from one map to another would mess it up but ?

    well i tried copying it and pasting it instead of dragging it no go. I didn't really think that would work but wth : )


  • Donators

    I found this from Iron war: https://forums.triplea-game.org/topic/73/iron-war-official-thread/4

    S
    Swampy Mar 31, 2017, 10:29 AM

    I have downloaded the map, but getting an error message:
    triplea.engine.version.bin:1.9
    games.strategy.engine.framework.startup.launcher.MapNotFoundException
    at games.strategy.triplea.ResourceLoader.getMapResourceLoader(ResourceLoader.java:57)
    at games.strategy.util.LocalizeHTML.localizeImgLinksInHTML(LocalizeHTML.java:87)
    0
    Frostion Admin Apr 1, 2017, 1:42 AM

    @Swampy - I think there were some problems with the download that was caused by mismatching names and stuff. NOW the map seems to be both downloadable and working. I already did a small fix. The kamikaze planes can now land on carriers.

    PS: Maybe you actually have to go to your map folder and delete the “iron War BETA” zip and properties file you downloaded, and then redownload the map. (Probably in the directory C:\Users\YOURNAME\triplea\downloadedMaps )
    The new working and updated map is called v2 in the download screen and v0.1.1 in the map selection window.

    Maybe it is a naming thing. I'll go through the xml and make sure they're all spelled the same.

    What exactly did you have @Frostion that was causing this ?

    Oh i see it says "map" not "image" but may be relevant 🙂

    well it's not spelling. they're both the same too


  • Moderators Admin

    @beelee

    Still I think the reason is this:

    @Panther said in Trouble Updating Map:

    @beelee The error is caused by a reference to the folder

    oztea_1939_global/doc/images/Neutral_Navy.png
    

    that does not exist inside the map-structure.

    Do you remember how that reference might have been included?

    ... unless the error message is not totally misleading. But I have no idea where the incorrect reference has its origin.

    Additionally...

    games.strategy.util.LocalizeHtml localizeImgLinksInHtml
    

    ... I am not sure where "Html" is used in that context, either.


  • Donators

    Finally got it to work but Idk why it did what it did. Needed this "doc" folder:

    Screenshot from 2019-11-11 19-53-43.png

    None of the other games have it. i added it to the error game and now it doesn't do it. I think I originally got it from one of Hepps games, TWW I think. Anyway, used a pile of units from other games before and never had this happen.

    Anyone know how I can get rid of that folder and not have the error show up ? There's only the one image in the doc folder.


Log in to reply