I need help for to fix the error


  • Admin

    @schulz You essentially need each nation to have the mechanizedInfantry tech, each land transport have isLandTransport, and each transportable unit have isLandTransportable:

        <attachment name="techAttachment" attachTo="Germany" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
          <option name="techCost" value="4"/>
          <option name="mechanizedInfantry" value="true"/>
        </attachment>
    
        <attachment name="unitAttachment" attachTo="Train" javaClass="games.strategy.triplea.attachments.UnitAttachment" type="unitType">
          <option name="isLandTransport" value="true"/>
        </attachment>
    
        <attachment name="unitAttachment" attachTo="germanInfantry" javaClass="games.strategy.triplea.attachments.UnitAttachment" type="unitType">
          <option name="isLandTransportable" value="true"/>
        </attachment>
    


  • Yes. I have this one.

    <attachment name="techAttachment" attachTo="Germany" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="techCost" value="10"/>
    <option name="mechanizedInfantry" value="true"/>
    </attachment>
    <attachment name="techAttachment" attachTo="Austria" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="techCost" value="10"/>
    <option name="mechanizedInfantry" value="true"/>
    </attachment>
    <attachment name="techAttachment" attachTo="Ottoman" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="techCost" value="10"/>
    <option name="mechanizedInfantry" value="true"/>
    </attachment>
    <attachment name="techAttachment" attachTo="Britain" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="techCost" value="10"/>
    <option name="mechanizedInfantry" value="true"/>
    </attachment>
    <attachment name="techAttachment" attachTo="France" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="techCost" value="10"/>
    <option name="mechanizedInfantry" value="true"/>
    </attachment>
    <attachment name="techAttachment" attachTo="Russia" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="techCost" value="10"/>
    <option name="mechanizedInfantry" value="true"/>
    </attachment>
    <attachment name="techAttachment" attachTo="Italy" javaClass="games.strategy.triplea.attachments.TechAttachment" type="player">
    <option name="techCost" value="10"/>
    <option name="mechanizedInfantry" value="true"/>
    </attachment>


  • Admin

    @schulz Ok, I updated my post with some more details. Tech looks ok. Can you check your units and post your latest XML here?



  • I have added <option name="isLandTransport" value="true"/> to train and <option name="isLandTransportable" value="true"/> to aagun, field_gun, heavy_gun, gas, infantry, cossack, stromtruppen, colonial, big_bertha and conscript.

    And I've got this one.

    UnitAttachment are either misspelled or exist only in a future version of TripleA. Setter: isLandTransportable

    I am using triplea 1.9.9.07621.


  • Admin

    @schulz Can you download the latest version of TripleA and retest: http://triplea-game.org/download/. Should be version 1.9.0.0.9687.


  • Donators Moderators Admin

    @schulz

    I recommend that you utilize the train model from TWW Beta. The trains are much better than any previous version of trains.


  • Moderators

    Just so you know, I intend to release a WW1 game on the House of Habsburg map immediately after HoH reaches a point of decent balance.


  • Admin

    I have moved this thread to Map Making as it seems to discuss several map making technicalities.
    By the way, always nice to see a new mapmaker and new maps in development 🙂



  • @General_Zod

    Currently I am using weltpolitic map's train on the map. But I can utilize TWW's trains why not. Before changing units I have to achieve a decent balance on the western front. Germany definitely should be able to conquer Belgium and Northwestern France but also shoul not be able to take Paris.

    I have placed units but of course it has not a decent balance yet.

    https://files.fm/u/wpytkdeh#_

    Also My Russia is stronger than France is it really logical?


  • Moderators

    @schulz I would have no problems myself talking abot whatever wherever, but I am under the understanding you are supposed to make a thread in "Maps & Mods", with the name of your map, to discuss the map in general (balance, historicity, etc.).


  • Donators Moderators Admin

    @schulz I think it is important to ask the developer of a map whether they are ok with you using their work to create a MOD before commencing the development of a project utilizing their initial designs. Especially when that person designed the map to create a scenario for the exact same time period in the first place.


  • Donators

    yea, even though we're open source here, it'd be a common courtesy imo. Especially with CrazyG's map being basically brand new.


  • Donators

    @Schulz Just to clarify, not trying to be a downer. : ) It's cool you're interested in map making and learning how the xml works. Just a informal etiquette thing : )

    As you've probably noticed, there's plenty of people who will help with answering questions.


  • Donators

    @Schulz here's some more advice

    Don't troll



  • ........



  • I need help for another xml file. I'd be grateful if anyone is able to detect the error. And I would like to learn that how do you detect errors when I am not able to.

    0_1537810193629_Domination_1914_No_Mans_Land_v2.xml


  • Moderators

    @schulz said in I need help for to fix the error:

    And I would like to learn that how do you detect errors when I am not able to.

    In past you would always get the error message in case the game was not working. Then that was disabled and an option added to show the error messages always. But now I cannot find that option in Engine Prefereces anymore? I'm talking about "Show Console Always".

    Also, I preferred how it worked in 1.8.0.9.


  • Donators Moderators Admin

    @cernel I believe they moved it to the game settings show console set as true



  • I've looked most likely there is no way to get error message in the current version. Is there any way to detect mistakes of xml besides getting error messages.

    Also I have tried to download older version. Neither this nor old version did work when I downloaded the older one. So I did delete the older one.